如何从ubuntu16.10升级到ubuntu17.04

author author     2023-04-11     704

关键词:

先决条件:

在执行Ubuntu升级之前,您应该做几件事情,例如备份重要的文件和文件夹,禁用或清除第三方PPA(升级过程将禁用这些) 并安装所有可用的更新。

最后一步很重要,所以请确保您在开始之前已经完全保持最新状态,终端输入以下命令:

sudo apt update && sudo apt dist-upgrade

完成了所有这一切准备,继续进行升级。

Ubuntu 16.10升级到17.04

升级16.10至17.04

您可以通过以下两种方式之一升级到Ubuntu 17.04:使用Software Updater应用程序或使用命令行。

无论您选择哪种升级方式,您都会获得相同的最终结果:Ubuntu 17.04。

Ubuntu将在4月13日正式发布公告之后的某个时候通知您Ubuntu有新版本可用。

此通知并不总是立即出现。 可能需要一点点耐心。 还要记住,在发布当天,Ubuntu服务器非常繁忙,升级可能比预期的要长。

如果你不想等待,或者想提早升级,你可以这样做。

要手动升级到Ubuntu 17.04,您需要在新的终端窗口中运行以下命令:

sudo do-release-upgrade -d

如下图所示,确认是否继续:

阅读在终端中显示的详细信息,如果你想继续输入Y,然后按Enter。

一旦完成下载,解压和安装,系统将提示您重新启动。

Ubuntu 16.04 LTS升级到17.04,将Ubuntu 16.04 LTS升级到17.04。

先你需要考虑是否确认进行升级,Ubuntu 16.04 是一个长期支持版本,5年的持续支持,升级后的Ubuntu 17.04只有9个月的支持。

如果您对上述问题的回答是“是”,那么您可以继续。 16.10用户可以直接升级到最新版本,Ubuntu 16.04需要两次和更长时间。

长期支持版本默认设置为仅升级到LTS版本。 要获知有一个较新的非LTS Ubuntu版本可用,您必须使用软件更新程序工具手动设置“选择加入”:

打开“软件和更新”

选择“更新”选项卡

找到标题为“通知我新的Ubuntu版本”

在下拉菜单中,从“长期支持版本”切换到“任何新版本”

切换后,您需要运行快速更新(无论如何都会提示您执行此操作),然后您需要升级到Ubuntu 16.10(是的,16.10)。sudo do-release-upgrade -d,一旦升级完成重新启动,请再次登录并运行该命令,这次升级到Ubuntu 17.04。sudo do-release-upgrade -d

根据具体问题类型,进行步骤拆解/原因原理分析/内容拓展等。
具体步骤如下:/导致这种情况的原因主要是……

参考技术A 采用以下方法把你的Ubuntu 16.10系统升级到Ubuntu 17.04系统,以下是升级方式:

先更新资源链接
root
$sudo apt-get update

升级版本,如果你的系统软件不是最新的,第一次升级有可能需要更新安装,耐心等待。

重新启动后再次使用此命令才可以升级版本。
$sudo update-manager -c -d

官方提供了从Ubuntu 16.10升级到Ubuntu 17.04系统的方法:http://www.linuxdiyf.com/linux/25434.html本回答被提问者采纳

ubuntu16升级到18

...级":一些基本设置即可赶脚: 另一篇帖子:ref: 如何从Ubuntu16.04升级至Ubuntu18.04LTS?-小众软件 查看详情

vps上ubuntu16.10系统如何安装图形界面

参考技术A工具/原料Ubuntu系统xrdpXFCE桌面环境方法/步骤1.首先我们要先升级一下软件源给安装桌面环境做准备。执行命令:apt-getupdate2.安装桌面环境或窗口管理器:apt-getinstallxubuntu-desktop这将为Ubuntu安装XFCE桌面环境。3.下面接着来... 查看详情

如何使用 apt-get 在 Ubuntu 18.04/17.04/16.10/16.04 LTS/15.10/15.04/14.10/14.04 LTS/13.10/13.04 上安装 Maven

】如何使用apt-get在Ubuntu18.04/17.04/16.10/16.04LTS/15.10/15.04/14.10/14.04LTS/13.10/13.04上安装Maven3?[关闭]【英文标题】:HowtoinstallMaven3onUbuntu18.04/17.04/16.10/16.04LTS/15.10/15.04/14.10/14.04LTS/13.10/13.04byusingapt-get?[closed]【 查看详情

尝试在 Ubuntu 18.04 上将 MySQL 服务器从 5.7 升级到 8.0 时出错

】尝试在Ubuntu18.04上将MySQL服务器从5.7升级到8.0时出错【英文标题】:ErrorswhiletryingtoupgradeMySQLserverfrom5.7to8.0onUbuntu18.04【发布时间】:2020-09-1908:29:17【问题描述】:我不知道是我做错了什么,还是出现了一些我看不到的缺陷。以下... 查看详情

安装ubuntu16.10后要做哪些事

参考技术A安装n有几种方式,最快捷的是用npm安装,前面的安装已经为这里打好了铺垫,现在只需要运行npminstall-gn,安装好后升级nodejsnlatestUseorinstallthelatestofficialrelease:$nlatestUseorinstallthestableofficialrelease:$nstable 查看详情

Ubuntu 16.10 上的 Anki 错误

】Ubuntu16.10上的Anki错误【英文标题】:AnkierroronUbuntu16.10【发布时间】:2017-01-0310:13:46【问题描述】:这是我尝试从命令行运行anki时得到的结果:`Traceback(mostrecentcalllast):File"/usr/bin/anki",line5,in<module>importaqtFile"/usr/share/anki/aqt/__... 查看详情

如何在 Ubuntu 16.10 上为 Python 3.6 安装 pip?

】如何在Ubuntu16.10上为Python3.6安装pip?【英文标题】:HowtoinstallpipforPython3.6onUbuntu16.10?【发布时间】:2017-07-2811:25:38【问题描述】:我想首先指出这个问题可能看起来像重复,但事实并非如此。我在这里看到的所有问题都是关于Py... 查看详情

此工具不支持从“宇宙”升级到“焦点”

...ool【发布时间】:2020-11-2103:30:35【问题描述】:检查新的Ubuntu版本不再支持您的Ubuntu版本。有关升级信息,请访问:http://www.ubuntu.com/releaseendoflife无法升级。我无法将ubuntu从18.10更新到20 查看详情

如何从 ubuntu 服务器以编程方式登录到 Yahoo

】如何从ubuntu服务器以编程方式登录到Yahoo【英文标题】:howtologintoYahooprogramaticallyfromanubuntuserver【发布时间】:2012-08-1201:17:26【问题描述】:我想从运行在ubuntu服务器上的脚本登录到我的yahoo帐户。我曾尝试将python与mechanize一起... 查看详情

ubuntu内核升级成功后,无法进入到桌面的解决方法

...生了什么事情。你可能会问,这里都进入不了Ubuntu系统,如何才能修改为控制台方式呢?因为我这里是升级内核,在Grub引导界面里,是可以看到旧内核版本(4.15)的,因此选择旧的内核启动Ubuntu便可。进入到系统后,修改grub配... 查看详情

如何在线将ubuntu18.04升级到ubuntu20.04

将Ubuntu18.04升级到Ubuntu20.04在将系统升级运行到下一个主要发行版本之前,请确保已备份当前系统,以使您可以恢复原状,以防万一。备份过程不在本指南的范围内。运行系统更新首先将Ubuntu18.04系统软件包更新和升级... 查看详情

安装ubuntu16.10后要做哪些事

...率的使用。$unity-tweak-tool 参考技术B.由于安装的是Windows和Ubuntu双系统,两个系统的时间不对,相差八小时,首先要调整系统时间,在Ubuntu16.10下进行。解决办法是输入命令:timedatectlset-local-rtctrue2.将启动器移动到屏幕下方。gsettin... 查看详情

在 Ubuntu 上将 jq 升级到 1.5

】在Ubuntu上将jq升级到1.5【英文标题】:Upgradingjqto1.5onUbuntu【发布时间】:2016-07-2713:17:58【问题描述】:所以它读作here:jq1.5位于官方Debian和Ubuntu存储库中。使用sudoapt-getinstalljq安装。还是:$sudoapt-getinstalljqReadingpackagelists...DoneBuild... 查看详情

从 Ubuntu 19.10 升级到 20.04 后缺少 Distutils 文件夹的问题

】从Ubuntu19.10升级到20.04后缺少Distutils文件夹的问题【英文标题】:ProblemwithmissingDistutilsfolderafterupgradingfromUbuntu19.10to20.04【发布时间】:2021-03-2915:58:32【问题描述】:从19.10升级到20.04后,我遇到了virtualenv和virtualenvwrapper的问题。... 查看详情

在 LAMPP for Ubuntu 中将 PHP 从 5.5 升级到 5.6

】在LAMPPforUbuntu中将PHP从5.5升级到5.6【英文标题】:UpgradePHPto5.6from5.5inLAMPPforUbuntu【发布时间】:2016-05-0702:05:24【问题描述】:Ubuntu版本:14.04/opt/lampp下有PHP5.5的现有LAMPP安装我只需要更新到PHP5.6。遵循以下步骤,但在makeinstall步... 查看详情

Ubuntu 14.04 - 将 Apache2 升级到 2.4.10

】Ubuntu14.04-将Apache2升级到2.4.10【英文标题】:Ubuntu14.04-upgradeApache2to2.4.10【发布时间】:2016-06-2602:17:54【问题描述】:我遇到了这个错误:https://bz.apache.org/bugzilla/show_bug.cgi?id=56480我似乎无法使用包含修复(2.4.10)的版本:#apt-cachepol... 查看详情

Docker - Ubuntu 20.04 升级后没有路由到主机

】Docker-Ubuntu20.04升级后没有路由到主机【英文标题】:Docker-noroutetohostafterUbuntu20.04upgrade【发布时间】:2021-04-0610:01:35【问题描述】:多年来,我一直在为一些应用程序使用docker-compose,最近,在将主机操作系统从Ubuntu18.04升级到U... 查看详情

Ubuntu 升级到 13.10 后 mCrypt 不存在

】Ubuntu升级到13.10后mCrypt不存在【英文标题】:mCryptnotpresentafterUbuntuupgradeto13.10【发布时间】:2013-10-2702:54:31【问题描述】:在我将系统从Ubuntu13.04升级到13.10后,apache、mysql和php配置出现了几个问题。我解决了其中的大部分问题... 查看详情