刚升级到 Ubuntu 16.04 但找不到 localhost/phpmyadmin

     2023-02-25     92

关键词:

【中文标题】刚升级到 Ubuntu 16.04 但找不到 localhost/phpmyadmin【英文标题】:Just upgraded to Ubuntu 16.04 but cannot find localhost/phpmyadmin 【发布时间】:2016-08-15 20:55:20 【问题描述】:

我刚刚将我的 Ubuntu 15.10 升级到 Ubuntu 16.04 现在的问题是,虽然系统里有php7、mysql、apache,但是页面localhost/phpmyadmin还是打不开。

这是显示的错误消息。

Mysql、apache 和 phpmyadmin 都安装好了。然而,问题似乎并没有停止。我知道我可以删除当前的 php7 并安装 php5,但我想让它在 php7 本身中工作。 (如果这是问题所在)

【问题讨论】:

nginx error.log 中有什么内容吗? 哦,抱歉,您使用的是 Apache 服务器,所以在终端输入 gedit /var/log/apache2/error.log 升级说明中有关于 Apache 或 MySQL 的内容吗? Apache 服务器真的在运行吗?那台机器上的其他页面(可能来自您的网络根目录)是否正确打开? @IsaacBennech 不,没有笔记。是的,Apache 服务器正在运行。并且没有其他页面没有运行 那么我肯定怀疑您的 Apache 安装有问题。如果它不能正确地提供页面,它应该记录一些东西;如果不是,那么还有其他东西坏了。不过,日志位置可能与 Ján Kyselica 建议的不同。这可能会帮助您找到访问日志unix.stackexchange.com/questions/38978/…——错误日志可能在同一个文件夹中。此外,请检查访问日志,看看它是否在您尝试访问期间记录了任何内容。 【参考方案1】:

你可以试试

sudo apt install php7.0-mbstring php-gettext

【讨论】:

【参考方案2】:

安装 libapache2-mod-php,这对我有用

【讨论】:

【参考方案3】:

我遇到了这个问题,因为我错误地从我的安装中删除了所有 php-* 包。所以尝试重新安装软件包,例如:

// Install missing packages for apache2
sudo apt-get install apache2

// Install phpmyadmin missing packages
sudo apt-get install phpmyadmin

// Install common php packages
sudo add-apt-repository ppa:ondrej/php
sudo apt-get update
sudo apt-get install php7.0-fpm php7.0-cli php7.0-common \
                     php7.0-json php7.0-opcache php7.0-mysql \
                     php7.0-phpdbg php7.0-mbstring php7.0-gd \ 
                     php7.0-imap php7.0-ldap php7.0-pgsql \ 
                     php7.0-pspell php7.0-recode php7.0-snmp \ 
                     php7.0-tidy php7.0-dev php7.0-intl \ 
                     php7.0-gd php7.0-curl php7.0-zip php7.0-xml

请注意,您可能不需要所有这些 php-* 包,但这取决于您当前的需求。

【讨论】:

【参考方案4】:

我安装了 php-mbstring php-gettext

sudo apt-get install php-mbstring php-gettext

然后我重新启动了 apache

sudo service apache2 restart

我希望这会有所帮助。

【讨论】:

【参考方案5】:

很久以前我也遇到过同样的问题。该问题已通过重新安装缺少的软件包得到解决,例如 apachemysqlphpMyAdminother missing PHP packages

【讨论】:

【参考方案6】:

升级到 ubuntu 16.10 后不久,我也遇到了类似的问题。然后没有任何工作,所以我卸载了包括php, apache, phpmyadmin 在内的所有内容并再次安装。这已经解决了这个问题。

【讨论】:

ubuntu16升级到18

参考技术Aref: ubuntu升级到ubuntu18.04版本步骤演示_百度经验#资源更新#软件升级#检查最新版本:#弹出窗口,提示ubuntu18.04现在可以安装,点击“升级":一些基本设置即可赶脚: 另一篇帖子:ref: 如何从Ubuntu16.04升级至Ubuntu... 查看详情

如何在 Ubuntu 16.04 中安装 Charles Proxy 4

】如何在Ubuntu16.04中安装CharlesProxy4【英文标题】:HowtoinstallCharlesProxy4inUbuntu16.04【发布时间】:2017-05-1013:46:59【问题描述】:我能够安装CharlesProxy3(sudoaptinstallcharles-proxy3),但找不到4的软件包。https://www.charlesproxy.com/documentation/inst... 查看详情

ubuntu16.04升级cmake

好文章值得分享https://zhuanlan.zhihu.com/p/93480024 查看详情

ubuntu16.04升级cmake(代码片段)

参考文章1:Ubuntu升级Cmake的正确方式照着上面这篇弄没啥问题我们ubuntu16.04目前用的稳定版是3.8.2https://cmake.org/files/v3.8/cmake-3.8.2.tar.gz参考文章2:Ubuntu16.04cmakeconfigure报错:CouldNOTfindOpenSSL,trytosetthepathto 查看详情

ubuntu16.04升级cmake(代码片段)

参考文章1:Ubuntu升级Cmake的正确方式照着上面这篇弄没啥问题我们ubuntu16.04目前用的稳定版是3.8.2https://cmake.org/files/v3.8/cmake-3.8.2.tar.gz参考文章2:Ubuntu16.04cmakeconfigure报错:CouldNOTfindOpenSSL,trytosetthepathto 查看详情

升级ubuntu16.04之后报错解决方法

升级Ubuntu16.04之后报错解:AstartjobisrunningforHolduntilbootprocessfinishesup(XminXs/nolimit)解决方法:Goinyoursafemodebyhitting SHIFT keyor ESC.selectnetworking,thendroptorootprompt.Thenrunfollowi 查看详情

无法在 python 中为 ubuntu 16.04 上的 libreoffice 导入 uno

】无法在python中为ubuntu16.04上的libreoffice导入uno【英文标题】:can\'timportunoinpythonforlibreofficeonubuntu16.04【发布时间】:2020-09-1909:32:00【问题描述】:我在ubuntu16.04上使用LO7.0.1.2和python3.7.6。已安装APSO,并且在LO中执行python脚本可以... 查看详情

如何从ubuntu16.10升级到ubuntu17.04

先决条件:在执行Ubuntu升级之前,您应该做几件事情,例如备份重要的文件和文件夹,禁用或清除第三方PPA(升级过程将禁用这些)并安装所有可用的更新。最后一步很重要,所以请确保您在开始之前已经完全保持最新状态,终... 查看详情

ubuntu16.04升级openssh(代码片段)

参考:Ubuntu16.04升级Openssh8.8P1Ubuntu16更新openssh8.81.安装Telent防止ssh出问题无法远程服务器服务器上安装telent服务端apt-getinstallopenbsd-inetdtelnetdtelnet/etc/init.d/openbsd-inetdrestart#启动服务netstat-anpt|grep23#查看telnet 查看详情

Ubuntu 16.04 屏幕仅完全冻结鼠标移动

...emoves【发布时间】:2016-12-1703:51:51【问题描述】:自从我升级了笔记本电脑(Clickhereforhardwarespecs.)后,我的屏幕通常会死机。主要在chrome或Firefox浏览器中。我很确定这是一个Nvidia驱动程序问题,但我似乎找不到解决方案。我正在... 查看详情

ubuntu16.04升级openssh(代码片段)

参考:Ubuntu16.04升级Openssh8.8P1Ubuntu16更新openssh8.81.安装Telent防止ssh出问题无法远程服务器服务器上安装telent服务端可客户端apt-getinstallopenbsd-inetdtelnetdtelnet/etc/init.d/openbsd-inetdrestart#启动服务netstat-anpt|grep23#查看te 查看详情

aosp代码repo时候需要python3.7,ubuntu16.04下升级python到3.7(代码片段)

第一步,增加ppa仓库:sudoadd-apt-repositoryppa:jonathonf/python-3.7第二步更新库sudoapt-getupdate第三步安装库sudoapt-getinstallpython3.7安装好了后需要对系统默认python切换:lrwxrwxrwx1rootroot268月162019dh_pypy->../ 查看详情

在 ubuntu 16.04 LTS 上运行 mongodb

...Ubuntu16.04LTS上将Mongodb作为服务运行?几天前,我将服务器升级到了Ubuntu16.04。我注意到我的MongoDB服务在我重新启动时没有启动。尝试使用sudoinitctlstartmongod没有成功。有人知道如何解决这 查看详情

安装 hadoop 时在 ubuntu 16.04 中找不到 jps 命令

】安装hadoop时在ubuntu16.04中找不到jps命令【英文标题】:jpscommandnotfoundinubuntu16.04whileinstallinghadoop【发布时间】:2017-03-1118:45:33【问题描述】:rana@ubuntu:/usr/local/hadoop/hadoop-2.7.3/bin$start-yarn.shstartingyarndaemonsstartingresourceman 查看详情

无服务器:在 ubuntu 16.04 中找不到命令

】无服务器:在ubuntu16.04中找不到命令【英文标题】:serverless:commandnotfoundinubuntu16.04【发布时间】:2017-12-2104:43:52【问题描述】:我正在尝试在Ubuntu16.04LTS中设置AWSServerless框架。我安装了Node.js并且还使用以下命令安装了无服务器... 查看详情

找不到发布文件的位置

...时间】:2012-04-2310:48:45【问题描述】:我最近将我的XCode升级到了4.3.2,并将我的操作系统升级到了Lion,这样我的应用程序就可以在IOS5.1plus上运行。我现在正在尝试升级几个旧应用程序,但找不到将应用程序文件上传到Apple的位... 查看详情

ubuntu升级版本

参考技术A当使用以下命令升级Ubuntu16.04到18.04时do-release-upgrade如果出现以下提示:CheckingforanewUbuntureleasePleaseinstallallavailableupdatesforyourreleasebeforeupgrading.可以用以下命令进行修复:(依次执行即可)sudoapt-getupdatesudoapt-getupgrade-ysudoap... 查看详情

在 Laravel - 使用 ubuntu 16.04 在 xampp 上找不到驱动程序

】在Laravel-使用ubuntu16.04在xampp上找不到驱动程序【英文标题】:InLaravel-couldnotfinddriveronxamppusingubuntu16.04【发布时间】:2021-01-2816:42:01【问题描述】:我正在开发PHP的xampp7.3版本。我面临以下错误。Illuminate\\Database\\QueryException:在文... 查看详情