升级到 Ubuntu 20.04 杀死 pip

     2023-03-16     19

关键词:

【中文标题】升级到 Ubuntu 20.04 杀死 pip【英文标题】:Upgrade to Ubuntu 20.04 killed pip 【发布时间】:2020-08-25 05:45:21 【问题描述】:

我从 19.10 升级到 Ubuntu 20.04,现在我无法使用 pip。

zeno:~$ pip --version

Command 'pip' not found, but there are 18 similar ones.

Python 已安装:

zeno:~$ python3 --version
Python 3.8.2

但如果我尝试插入 pip,我会得到:

    zeno:~/Desktop/tetris$ sudo apt install python3-pip
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    python3-pip is already the newest version (20.0.2-5ubuntu1).
    The following packages were automatically installed and are no longer required:
     dh-python elpa-async enchant gedit-plugin-zeitgeist gir1.2-mutter-5
     gnome-software-common libappstream-glib8 libapt-pkg5.90
     libboost-date-time1.67.0 libboost-iostreams1.67.0 libbrlapi0.6
     libcodec2-0.8.1 libcroco3 libdns-export1104 libdns1104 libdvdread4
     libegl1-mesa libenchant1c2a libept1.5.90 libevent-2.1-6 libexiv2-14
     libfprint0 libgeoip1 libgit2-27 libglvnd-core-dev libgnome-desktop-3-18
     libgspell-1-1 libgutenprint-common libgutenprint9 libgweather-3-15 libicu63
     libiptc0 libisc-export1100 libisc1100 libisc1105 libisl21 liblivemedia64
     liblouis17 liblwres161 libmicrodns0 libmozjs-60-0 libmutter-5-0 libmysofa0
     libnettle6 liboauth0 libperl5.28 libplymouth4 libpoppler90
     libpython3.7-minimal libqpdf21 libsnmp30 libusbmuxd4 libx11-xcb-dev
     libx265-176 libxcb-dri2-0-dev libxcb-dri3-dev libxcb-shape0-dev
     libxcb-sync-dev libxcb-xfixes0-dev libxshmfence-dev libzeitgeist-2.0-0
     perl-modules-5.28 printer-driver-gutenprint python-gobject-2
     python3-asn1crypto python3-pypdf2 python3.7-minimal ubuntu-system-service
     x11proto-composite-dev x11proto-fixes-dev
   Use 'sudo apt autoremove' to remove them.
   0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

我迷路了。感谢您的帮助

更新

我使用 venv 创建虚拟环境。当没有激活​​venv时,我可以使用pip3:

zeno:~/Desktop/tetris$ pip3 -V
pip 20.0.2 from /usr/lib/python3/dist-packages/pip (python 3.8)

但是如果我激活了一个venv,它就不起作用了:

(.tetris) zeno:~/Desktop/tetris$ pip3
Traceback (most recent call last):
  File "/home/zeno/Desktop/tetris/.tetris/bin/pip3", line 6, in <module>
    from pip._internal import main
ModuleNotFoundError: No module named 'pip'

感谢您的建议和持续的帮助。

更新

我尝试删除 venv 并创建一个新的,但似乎我需要 pip 工作才能做到这一点:

zeno:~/Desktop/tetris$ python3 -m venv .tetris

给予:

The virtual environment was not created successfully because ensurepip is not
available.  On Debian/Ubuntu systems, you need to install the python3-venv
package using the following command.

    apt-get install python3-venv

You may need to use sudo with that command.  After installing the python3-venv
package, recreate your virtual environment.

Failing command: ['/home/zeno/Desktop/tetris/.tetris/bin/python3', '-Im', 'ensurepip', '--upgrade', '--default-pip']

【问题讨论】:

它叫pip3吗? 试试sudo apt install python-is-python3。它应该使pythonpip 分别指向python3pip3 删除旧的环境,并创建一个新的,它可能会完成这项工作 谢谢,我试过了,我的问题更新了。 @EricChancellor 你有没有解决这个问题?遇到同样的问题。 【参考方案1】:

有时在操作系统升级后,您需要重新安装软件包。试试:

sudo apt install --reinstall python3-pip

【讨论】:

感谢您的回答。这不起作用,但我已经更新了我的问题。 @EricChancellor 我也面临或多或少相同的问题/错误并陷入 virtualenvwrapper 问题。只需删除旧的 .virtualenvwrapper 目录并点击sudo apt install --reinstall python3-pip【参考方案2】:

我不得不清除 python3-venv 并重新安装它:

zeno:~$ sudo apt purge python3-venv

然后

zeno:~$ sudo apt install python3-venv

谢谢大家

【讨论】:

【参考方案3】:

dobairoland 在 esp-idf github(问题 4474)上给出了最适合我的解决方案,如 Espressif Docs 中所示:

sudo apt-get install python3 python3-pip python3-setuptools

sudo update-alternatives --install /usr/bin/python python /usr/bin/python3 10

替代方案 (1):起初,我能够使用使用 pip 硬编码的第 3 方 bash 安装脚本的别名来解决此问题(之前提到的安装/重新安装都不适合我) - 所以这也是一种选择:

sudo apt-get install python3-pip
alias pip="pip3"

这个(诚然不太优雅的选项)可能对脚本有帮助:

if [ "$(cat /etc/os-release | grep VERSION_ID)" == 'VERSION_ID="20.04"' ]; then
 alias pip="pip3"
else 
  echo "no pip alias"
fi

替代方案 (2) 还有 this hack 在技术上对我有用,但将已弃用的软件强制到系统上可能不是一个好主意:

wget https://bootstrap.pypa.io/get-pip.py
sudo python2.7 get-pip.py

【讨论】:

【参考方案4】:

我发现最简单的方法就是删除虚拟环境文件夹,重新创建它并使用 pip 重新安装依赖项,现在又可以使用了:)

【讨论】:

【参考方案5】:

我在 ubuntu 20 上遇到了同样的问题。我用这个 pip3 install --upgrade pip 修复了它

【讨论】:

将 Ubuntu 升级到 20.04 后 Cassandra 无法工作

】将Ubuntu升级到20.04后Cassandra无法工作【英文标题】:CassandranotworkingafterupgradeUbuntuto20.04【发布时间】:2020-10-2216:46:18【问题描述】:Cassandra.service正在运行但无法连接。Cqlsh也不行【问题讨论】:我已经在docker中安装了Cassandra,... 查看详情

升级到 Ubuntu 20.04 后,python 3.7 venv 损坏

】升级到Ubuntu20.04后,python3.7venv损坏【英文标题】:python3.7venvbrokenafterupgradetoUbuntu20.04【发布时间】:2020-08-1520:55:41【问题描述】:我刚刚升级到Ubuntu20.04。我在虚拟环境中使用Django处理python3.7项目,所以即使升级发行版(涉及... 查看详情

如何在线将ubuntu18.04升级到ubuntu20.04

将Ubuntu18.04升级到Ubuntu20.04在将系统升级运行到下一个主要发行版本之前,请确保已备份当前系统,以使您可以恢复原状,以防万一。备份过程不在本指南的范围内。运行系统更新首先将Ubuntu18.04系统软件包更新和升级... 查看详情

ubuntu20.04+virtualbox相关

...​​​​安装SSH​​​​apt换源​​​​pip换源​​​​升级Python​​​​开启远程桌面(windows连接,desktop版ubuntu)​​​​升级CMake3.22​​​​安装Samba​​​​安装MosquittoMQTT​​​​安装EMQXMQTT​​​​安装Redis​​​​安装L... 查看详情

从 Ubuntu 19.10 升级到 20.04 后缺少 Distutils 文件夹的问题

】从Ubuntu19.10升级到20.04后缺少Distutils文件夹的问题【英文标题】:ProblemwithmissingDistutilsfolderafterupgradingfromUbuntu19.10to20.04【发布时间】:2021-03-2915:58:32【问题描述】:从19.10升级到20.04后,我遇到了virtualenv和virtualenvwrapper的问题。... 查看详情

升级到 Ubuntu 20.04 后 PHP MySQLi 不再工作 [重复]

】升级到Ubuntu20.04后PHPMySQLi不再工作[重复]【英文标题】:PHPMySQLinotworkinganymoreafterupgradetoUbuntu20.04[duplicate]【发布时间】:2020-09-1422:12:20【问题描述】:我确实安装了php7.4-mysql,错误在下面,其余在标题中PHP致命错误:未捕获的错... 查看详情

将 ubuntu 18.04 升级到 20.04 但软件包仍然是 +bionic1

】将ubuntu18.04升级到20.04但软件包仍然是+bionic1【英文标题】:upgradeubuntu18.04to20.04butpackagesremain+bionic1【发布时间】:2020-08-2022:57:40【问题描述】:升级到ubuntu20.04后,一些包仍保留在+bionic1版本中sudoaptlist|greppython3.8WARNING:aptdoesnotha... 查看详情

将 ubuntu 18.04 升级到 20.04 后,简单的 hello world snap 不起作用

】将ubuntu18.04升级到20.04后,简单的helloworldsnap不起作用【英文标题】:Simplehelloworldsnapisnotworkingafterupgradeofubuntu18.04to20.04【发布时间】:2021-03-2712:12:53【问题描述】:最近,我开始研究捕捉。我已经学会了在Ubuntu18.04上使用简单的... 查看详情

如何在 Ubuntu 20.04 中为 Python2.7 安装 pip

】如何在Ubuntu20.04中为Python2.7安装pip【英文标题】:HowcanIinstallpipforPython2.7inUbuntu20.04【发布时间】:2021-01-2511:57:19【问题描述】:有什么方法可以为“Python2.7”安装“pip”吗?我可以通过安装python2.7sudoaptinstallpython2-minimal我尝试... 查看详情

Ubuntu 20.04 升级,Python 缺少 libffi.so.6

】Ubuntu20.04升级,Python缺少libffi.so.6【英文标题】:Ubuntu20.04upgrade,Pythonmissinglibffi.so.6【发布时间】:2020-09-0414:55:40【问题描述】:我最近将我的操作系统升级到了Ubuntu20.04LTS。现在,当我尝试在Python中导入像Numpy这样的库时,出现... 查看详情

在 Ubuntu 20.04 中使用 pip 安装 onnx 时出错

】在Ubuntu20.04中使用pip安装onnx时出错【英文标题】:ErrorswheninstallingonnxwithpipinUbuntu20.04【发布时间】:2020-08-0912:01:07【问题描述】:我正在尝试在全新的Ubuntu20.04安装中安装onnx,但我遇到了以下错误。看来我需要protobuf编译器,... 查看详情

如何在 Ubuntu 20.04 上为 Python 3.9 安装 pip

】如何在Ubuntu20.04上为Python3.9安装pip【英文标题】:HowtoinstallpipforPython3.9onUbuntu20.04【发布时间】:2021-04-1502:13:16【问题描述】:Ubuntu20.04附带Python3.8。我无法卸载Python3.8,但我需要Python3.9我继续安装Python3.9:sudoadd-apt-repositoryppa:de... 查看详情

如何在 ubuntu 20.04 上安装 python3-pip

】如何在ubuntu20.04上安装python3-pip【英文标题】:Howtoinstallpython3-piponubuntu20.04【发布时间】:2020-09-3016:47:18【问题描述】:我在PC上安装了Ubuntu20.04。然后我尝试开始并为python3安装pip。然而,似乎没有任何工作。这是我迄今为止尝... 查看详情

ubuntu20.04升级到22.04中遇到的问题(byquqi99)(代码片段)

...’sudodo-release-upgrade-d-fDistUpgradeViewNonInteractive’将ubuntu20.04升级到了ubun 查看详情

ubuntu20.04升级到22.04中遇到的问题(byquqi99)(代码片段)

...’sudodo-release-upgrade-d-fDistUpgradeViewNonInteractive’将ubuntu20.04升级到了ubun 查看详情

无法找到包 python-pip Ubuntu 20.04

】无法找到包python-pipUbuntu20.04【英文标题】:Unabletolocatepackagepython-pipUbuntu20.04【发布时间】:2020-09-1020:05:03【问题描述】:我正在尝试安装mininet-wifi。下载后,我一直使用以下命令安装它:sudoutil/install.sh-Wlnfv但是,我不断收到... 查看详情

升级到 ubuntu-16.10 后 Pip 不起作用

】升级到ubuntu-16.10后Pip不起作用【英文标题】:Pipdoesnotworkafterupgradetoubuntu-16.10【发布时间】:2017-06-3007:14:07【问题描述】:与pip一起运行命令会出现以下错误。甚至命令pip-V也会产生以下错误。我读到错误是由于setuptools版本31.0.... 查看详情

如何在已经安装 Python 3.4 的 Docker 容器中升级到 Python 3.5? (我在 Ubuntu 20.04 上运行 Docker 容器)

】如何在已经安装Python3.4的Docker容器中升级到Python3.5?(我在Ubuntu20.04上运行Docker容器)【英文标题】:HowtoupgradetoPython3.5inaDockercontainerthathasalreadyinstalledPython3.4?(I\'mrunningDockercontainersonUbuntu20.04)【发布时间】:2021-09-0510:09:51【问... 查看详情