升级安装 Android-Studio Ubuntu 18.04 的 CMake 版本

     2023-02-23     282

关键词:

【中文标题】升级安装 Android-Studio Ubuntu 18.04 的 CMake 版本【英文标题】:Upgrade CMake version installed with Android-Studio Ubuntu 18.04 【发布时间】:2018-12-30 11:58:59 【问题描述】:

我最近在 Ubuntu 18.04 上安装了 Android Studio,为 Android 做一些原生 C++ 开发。在编译需要 cmake 3.9 或更高版本的项目时(由于 cmake 依赖项),我发现 Android Studio 安装的 cmake 版本只有 3.6 版本。有没有一种干净的方法可以通过 SDK Manager 升级随 Android Studio 安装的 cmake 版本?

我正在运行 Android Studio 版本 3.1.3 并从 SDK Manager -> SDK 工具安装了 cmake。

【问题讨论】:

【参考方案1】:

来自官方Documentation,

SDK 管理器包括 CMake 的分支版本,最高版本为 3.6.4。如果您想使用 CMake 版本 3.7 或更高版本,请执行以下操作:

    将 Android Studio 更新至 3.0 或更高版本,并将 Gradle 的 Android 插件更新至 3.0.0 或更高版本。

    Download and install CMake 3.7 或更高版本,来自 CMake 官方网站。

    在模块的 build.gradle 文件中指定您希望 Gradle 使用的 CMake 版本:

    android externalNativeBuild cmake version "3.7.1"

    要么将 CMake 安装的路径添加到 PATH 环境变量中,要么将其包含在项目的 local.properties 文件中,如 cmake.dir="path-to-cmake"。如果 Gradle 无法找到您在 build.gradle 文件中指定的 CMake 版本,则会出现构建错误。如果设置此属性,Gradle 将不再使用 PATH 来查找 CMake。

希望对你有帮助!

【讨论】:

【参考方案2】:

同样来自documentation:

虽然不是最佳做法,但您可以通过在 build.gradle 条目的末尾添加 + 来将 CMake 版本指定为最低版本,例如 3.10.2+

这将启用您问题的“或更高”部分

【讨论】:

它不再出现在文档中,这条评论似乎是 CMake 在 Android Studio 的 Gradle 插件上的唯一参考。但它仍然有效!【参考方案3】:

Preference -> System Settings -> Android SDK 然后选择SDK Tools 选项卡

在该选项卡下找到Cmake 部分,选中具有更高版本的框并取消选中其余部分。然后应用并重新同步项目。

【讨论】:

androidstudio怎么在线升级

...新包拷贝至AndroidStudio的安装目录,比如安装目录为D:\android-studio,将下载的jar拷贝到该目录下即可。 查看详情

wdcp在ubunt下的安装(代码片段)

wgethttp://dl.wdlinux.cn/files/lanmp_v3.tar.gztar-xzvflanmp_v3.tar.gzsudoshlanmp.sh如果第三步后出现了错误dpkg-reconfiguredash选择NO输入sudoshlanmp.sh等一段时间后安装完毕 查看详情

01_ubunt14.04的安装

...发用Ubuntu  1、推荐典型,随意。 2、Now,直接安装程序光盘映像。如果选择第二个的,各种问题。黑屏,或者不动  3、Next  4、Next  5、安装完 查看详情

ubunt安装django(代码片段)

1、简介Django是一个可以使Web开发工作愉快并且高效的Web开发框架。使用Django,使你能够以最小的代价构建和维护高质量的Web应用。Django特点强大的数据功能:拥有强大的数据库操作接口(QuerySetAPI),如需要也能执行原生SQL。自... 查看详情

ubunt_配置_nfs

nfs服务器的安装配置和使用  1、将已经制作好的文件系统rootfs.tar.gz拷贝到/opt,并解压tar-xvfrootfs.tar.gz 2、安装nfs服务器:1》安装NFSserver端口映射和服务             &n 查看详情

ubunt_配置_samba

samba服务的安装及配置 一、安装:sudoapt-getinstallsamba二、配置:1、创建一个需要共享的目录,并修改权限:[email protected]:~$mkdir1703[email protected]:~$sudochmod7771703/-R2、打开配置文件:[email protected]:~$sudovim/etc/samb 查看详情

Android-studio 3.4.0-3.4.2 Gradle 错误:没有为属性“manifestOutputDirectory”指定值

】Android-studio3.4.0-3.4.2Gradle错误:没有为属性“manifestOutputDirectory”指定值【英文标题】:Android-studio3.4.0-3.4.2GradleERROR:Novaluehasbeenspecifiedforproperty\'manifestOutputDirectory\'【发布时间】:2019-09-2518:17:01【问题描述】:当升级到android-stu 查看详情

ubunt_配置_tftp

 tftp服务器的安装与配置:tftp主要用于嵌入式交叉开发环境的搭建,传输文件。 1、创建tftp的工作目录,并修改权限sudomkdir /tftpbootsudochmod777/tftpboot 2、安装:sudoapt-getinstalltftptftpdopenbsd-inetd 3、打开配置文件 ... 查看详情

在 USB 调试时,Android-Studio 无法使用 ArrayOutOfBounds 异常

】在USB调试时,Android-Studio无法使用ArrayOutOfBounds异常【英文标题】:Android-StudioisunusablewithArrayOutOfBoundsexceptionswhileUSBdebugging【发布时间】:2015-02-0223:11:38【问题描述】:我很难在Opensuse13.2上安装可用的AndroidStudio。我已经尝试过Jav... 查看详情

mint/ubunt日常所需命令软件安装

网络安装软件安装搜狗输入法sudodpkg-ihttp://cdn2.ime.sogou.com/dl/index/1571302197/sogoupinyin_2.3.1.0112_amd64.deb安装adobeplayersudoaptinstalladobe-flashplugin-y安装wpswgethttps://wdl1.cache.wps.cn/wps/download/ep/Linux2019/8865/wps-office_11.1.0.8865_amd64.debdpkg-iwps-office_11.1... 查看详情

android升级sdk

google被墙,在线升级不了sdk下载地址:http://tools.android-studio.org/index.php/sdk下载下来后放到目录:sdkplatforms本文出自“陪你度过漫长岁月”博客,请务必保留此出处http://4774721.blog.51cto.com/4764721/1796157 查看详情

android-studio中view-binding的使用

参考技术A首先需要使用AndroidStudio3.6Canary11之上的版本,升级gradleplugin版本到3.6.0beta01以上在build.gradle中修改如下在android中添加如下android...  buildFeatures   viewBindingtrue  ...在项目中开启了ViewBinding后,就会... 查看详情

pip3install--upgradepip升级安装后无法使用的解决步骤(代码片段)

本机环境:Ubunt16.04:python2.7+python3.6笔者在使用pip3更新模块的时候,提示pip3的版本比较旧8.0.1,可以更新到最新版19.1.1,随手更新了之后就不能使用了,报Nomodulenamed‘pip._internal‘的错误,网上找了一些方法仍然不行,几乎想重装系统了网... 查看详情

添加库 Android-studio

】添加库Android-studio【英文标题】:AddingalibraryAndroid-studio【发布时间】:2013-10-1104:28:05【问题描述】:在我的项目中添加achartengine-1.1.0.jar时遇到问题。当我添加compilefile(\'libs.achartengine-1.1.0.jar\')在build.gradle中,Gradle显示以下消息... 查看详情

Android-Studio(或一般的 IDEA)重构多个源集

】Android-Studio(或一般的IDEA)重构多个源集【英文标题】:Android-Studio(orIDEAingeneral)refactorovermultiplesourcesets【发布时间】:2015-04-1619:12:44【问题描述】:处理多个源集重构问题的好方法是什么?例如。有不同的风格——或者现在... 查看详情

如何解决 android-studio 中的“清单合并失败”错误?

】如何解决android-studio中的“清单合并失败”错误?【英文标题】:HowtoSolve\'Manifestmergerfailed\'errorinandroid-studio?【发布时间】:2016-06-1606:41:18【问题描述】:来自androidmanifest.xml的错误:任务\':app:processDebugManifest\'清单执行失败合... 查看详情

是否可以在 Android-Studio 或 IntelliJ 上使用 SWT?

】是否可以在Android-Studio或IntelliJ上使用SWT?【英文标题】:IsitpossibletouseSWTonAndroid-StudioorIntelliJ?【发布时间】:2016-07-0613:14:02【问题描述】:我使用Android-Studio已经很久了,在Eclipse上我已经习惯了。我希望为PC(windows、Linux、macO... 查看详情

android-studio缓存文件夹配置

======================================== 查看详情