在 Ubuntu 18.04 WSL 上安装无人值守的 MySQL 8 社区

     2023-02-25     66

关键词:

【中文标题】在 Ubuntu 18.04 WSL 上安装无人值守的 MySQL 8 社区【英文标题】:Unatttended MySQL 8 community install on Ubuntu 18.04 WSL 【发布时间】:2019-11-17 23:43:49 【问题描述】:

我正在尝试在没有任何提示的情况下在 Ubuntu(即 Linux 的 Windows 子系统)上安装 MySQL 8。

我有以下脚本:

apt-key add --keyserver pgp.mit.edu --recv-keys 5072E1F5
echo 'deb http://repo.mysql.com/apt/ubuntu/ bionic mysql-8.0' > /etc/apt/sources.list.d/mysql.list

apt-get update --yes
apt-get install --yes debconf-utils
echo 'mysql-community-server mysql-community-server/root-pass password' | sudo debconf-set-selections
echo 'mysql-community-server mysql-community-server/re-root-pass password' | sudo debconf-set-selections
apt-get install --yes mysql-community-server

(部分构造感谢this question 中的答案)

它似乎工作正常,除了它提示我选择身份验证方法...我想选择 mysql_native_password 并且这样做而不被交互式提示。

我猜解决方案是另一个 debconf-set-selections 设置,但是......除了询问这种情况下它是什么......在某处是否有所有可能选项的参考?

还有一个问题是 apt-get 说为服务创建了符号链接,但没有创建服务......但这并不是真正的阻碍,因为我只是将 WSL 用作测试场对于一个实际的 Ubuntu 服务器,我认为这会起作用......希望。

EDIT1:别管原来的问题...我设法找到了答案here 这导致偶然发现this dockerfile

所以我最终添加了

echo 'mysql-community-server mysql-server/default-auth-override select Use Legacy Authentication Method (Retain MySQL 5.x Compatibility)' | sudo debconf-set-selections

是我需要的线...

但是,另一个可能是 WSL 特定的问题仍然存在……也就是说,没有创建 MySQL 服务。我应该注意,当我在 WSL 之外安装 MySQL 时,服务器已关闭,特别是为了让 WSL 可以运行。

我在安装时得到以下输出,接近尾声:

Setting up mysql-community-server (8.0.16-2ubuntu18.04) ...
update-alternatives: using /etc/mysql/mysql.cnf to provide /etc/mysql/my.cnf (my.cnf) in auto mode
dpkg: error processing package mysql-community-server (--configure):
 installed mysql-community-server package post-installation script subprocess returned error exit status 1
Processing triggers for libc-bin (2.27-3ubuntu1) ...
Errors were encountered while processing:
 mysql-community-server
E: Sub-process /usr/bin/dpkg returned an error code (1)

我能找到的唯一与之相关的是完全重新安装的建议,但即使重新安装 WSL 实例也不能解决这个问题。

EDIT2:添加

apt-get dist-upgrade --yes --allow-remove-essential --allow-change-held-packages

修复了上面的错误,尽管没有任何错误,服务仍然没有创建。

【问题讨论】:

【参考方案1】:

我通过将 /etc/init.d/mysql 文件从另一个 WSL 实例(通过升级安装的 mysql 8)复制到 /etc/init.d 来修复丢失的 mysql 服务

sudo service mysql start

返回 [fail],但 mysql 守护进程运行良好。

否则,我看到人们通过先从 MySQL 的 repo 安装较低版本,然后升级到 mysql 8 来更干净地实现这一点。

【讨论】:

自定义wsl安装位置以及多wsl共存(代码片段)

...tps://docs.microsoft.com/en-au/windows/wsl/install-manual,比如下载的Ubuntu18.04将下载的文件的后缀Appx改为zip,然后解压到你想要安装该wsl的位置。比如像安装到Z盘,则解压到Z盘。比如我当前所在目录是在Z,解压后的目录是Ubuntu18.04onWindows_... 查看详情

无法在 WSL 上安装 mysql-server

...发布时间】:2019-08-0306:45:24【问题描述】:我在WSL上运行Ubuntu18.04,我正在尝试安装MySQL-server我一直收到所附屏幕截图中显示的错误..我已经尝试了几次aptremove--purgeMySQL*apt-get自动删除apt-get自动清理sudodpkg--configure 查看详情

在 WSL2 上安装 TensorFlow-GPU

...带有NVIDIAGPU的WSL2上成功安装了Tensorflow-GPU?我在WSL2上有Ubuntu18.04,但正在努力安装NVIDIA驱动程序。如果我迷路了,任何帮助将不胜感激。【问题讨论】:您是否遵循了本指南?docs.nvidia.com/c 查看详情

Ruby2d 在 Ubuntu 18.04 上的 WSL2 中无法工作 - 出现错误“没有可用的视频设备”

】Ruby2d在Ubuntu18.04上的WSL2中无法工作-出现错误“没有可用的视频设备”【英文标题】:Ruby2dnotworkinginWSL2onUbuntu18.04-Gettingerror"Noavailablevideodevice"【发布时间】:2022-01-0305:31:32【问题描述】:我在Ubuntu18.04上使用WSL2在Windows10... 查看详情

在 Ubuntu 18.04 上安装 RVM 时出错

】在Ubuntu18.04上安装RVM时出错【英文标题】:ErrorwhileinstallingRVMonUbuntu18.04【发布时间】:2018-12-2723:54:54【问题描述】:我尝试在新版本的Ubuntu18.04上安装RVM。但是我收到以下错误:"Errorrunning\'requirements_debian_libs_installgawkg++gccautoconf... 查看详情

在 WSL2 Ubuntu 上安装 npm

】在WSL2Ubuntu上安装npm【英文标题】:InstallingnpmonWSL2Ubuntu【发布时间】:2021-03-1602:55:17【问题描述】:我有一个需要sass/scss的Laravel应用程序。我正在尝试使用npminstall安装NPM,但它一直告诉我npm错误!代码EBADPLATFORMnpm错误!notsupfs... 查看详情

我无法在 ubuntu 18.04 上安装 mysql

】我无法在ubuntu18.04上安装mysql【英文标题】:Icannotinstallmysqlonubuntu18.04【发布时间】:2020-06-0717:04:45【问题描述】:我正在尝试在我的ubuntu18.04上安装mysql-server,但出现dpkg错误sudoapt-getinstallmysql-server之后的终端输出是正在读取包... 查看详情

在 ubuntu 18.04 上安装 opencv 2.4.9

】在ubuntu18.04上安装opencv2.4.9【英文标题】:installingopencv2.4.9onubuntu18.04【发布时间】:2018-06-0310:58:07【问题描述】:我在我的电脑上安装了ubuntu18.04,并且我设法安装了最新版本的opencv。不过,我需要在我的电脑上运行旧版本的op... 查看详情

在ubuntu18.04系统上安装最新的adobeflashplayer

在本文中,我们将介绍在Ubuntu18.04桌面版系统上安装最新版AdobeFlashPlayer。请按照以下步骤在Ubuntu18.04系统上安装AdobeFlashPlayer。 AdobeFlashPlayer介绍AdobeFlashPlayer是一种轻量级插件,适用于在AdobeFlash网站和平台上传输视频,音频和... 查看详情

shwkhtmltopdf安装在ubuntu18.04上(代码片段)

查看详情

在 Ubuntu 18.04 上安装 nodemon 时出错

】在Ubuntu18.04上安装nodemon时出错【英文标题】:errorwheninstallingnodemononUbuntu18.04【发布时间】:2018-12-1907:44:39【问题描述】:当我用安装nodemonsudonpmi--save-devnodemon我收到以下错误消息:npmERR!path/home/dominikpatera/Dropbox/Projekty/Fytwa/server/... 查看详情

如何在虚拟机Ubuntu 18.04上安装catkin

】如何在虚拟机Ubuntu18.04上安装catkin【英文标题】:HowtoinstallcatkinonavirtualmachineUbuntu18.04【发布时间】:2019-09-2317:11:48【问题描述】:我觉得我有靛蓝...我按照说明操作:https://wiki.ros.org/catkin#Installing_catkin有人可以帮我解决这个问... 查看详情

SQLSTATE[HY000] [2002] 连接被拒绝。使用 WSL2 Ubuntu 18.04 托管在 Docker 上的 Laravel API

】SQLSTATE[HY000][2002]连接被拒绝。使用WSL2Ubuntu18.04托管在Docker上的LaravelAPI【英文标题】:SQLSTATE[HY000][2002]Connectionrefused.LaravelAPIhostedonDockerwithWSL2Ubuntu18.04【发布时间】:2020-11-1214:03:02【问题描述】:我正在尝试通过邮递员为我在dock... 查看详情

在 Ubuntu 18.04 LTS 上安装 wordpress

】在Ubuntu18.04LTS上安装wordpress【英文标题】:InstallwordpressonUbuntu18.04LTS【发布时间】:2019-05-0907:45:56【问题描述】:我正在尝试,但遇到了问题。我正在一步一步做每一件事。我安装了这些东西,我也检查了状态:Apache(状态为... 查看详情

如何在 Ubuntu 18.04 上安装最新的 openjdk 12

】如何在Ubuntu18.04上安装最新的openjdk12【英文标题】:Howtoinstallthelatestopenjdk12onUbuntu18.04【发布时间】:2019-09-2102:10:43【问题描述】:我已经通过发出命令安装了默认jdk:apt-getinstalldefault-jdk这将安装openjdk11并且apt-get似乎将文件安... 查看详情

sh在ubuntu18.04上安装golang(代码片段)

查看详情

sh在ubuntu18.04上安装nginx(代码片段)

查看详情

无法在 Ubuntu 18.04 上安装 Azure-cognitiveservices-speech

】无法在Ubuntu18.04上安装Azure-cognitiveservices-speech【英文标题】:cannotinstallAzure-cognitiveservices-speechonUbuntu18.04【发布时间】:2020-08-1022:06:49【问题描述】:晚上好。我尝试在UbuntuMate18.04上安装Azure-cognitiveservices-speech,但收到错误:... 查看详情